Item Outage - Foot Locker $50 eGift Cards - 8/19/2019
Incident Report for Tango Card
Resolved
This outage is now resolved.
Posted 25 days ago. Aug 22, 2019 - 12:52 PDT
Identified
Foot Locker $50 eGift Cards are currently out of stock through our supplier. We will post an update as soon as the item becomes available again.
Posted 28 days ago. Aug 19, 2019 - 12:40 PDT
This incident affected: Item.