Item Outage - David Jones eGift Card $25.00
Incident Report for Tango Card
Resolved
This outage has ended.
Posted 21 days ago. Oct 01, 2019 - 08:33 PDT
Identified
We are experiencing and outage on David Jones eGift Card $25.00. The affected UTID is UTID:U114035.

More is on order, and we expect to have it back in stock soon.
Posted 23 days ago. Sep 29, 2019 - 18:23 PDT
This incident affected: Item.