Item Outage: NFL Shop $25 - 10/3/19
Incident Report for Tango Card
Resolved
This outage has been resolved.
Posted 15 days ago. Oct 07, 2019 - 14:35 PDT
Identified
We are currently out of inventory for NFL Shop $25. We will post an update when this reward is once again available.

The affected UTID is U570772.
Posted 19 days ago. Oct 03, 2019 - 02:07 PDT
This incident affected: Item.