Customer reporting they can not see credit card info
Incident Report for Tango Card
Resolved
This incident has been resolved.
Posted Apr 24, 2024 - 09:37 PDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 23, 2024 - 16:54 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 23, 2024 - 16:05 PDT
Investigating
Some customers are reporting they are unable to see their credit card information.
TangoCard is investigating and has mitigated the immediate problem.
TangoCard is actively resolving this issue for our impacted customers

We will provide updates as more information is available.
Posted Apr 23, 2024 - 15:50 PDT
This incident affected: Rewards Genius - Production.