Item Outage: Argos eGift Cards - 8/13/2019
Incident Report for Tango Card
Resolved
This incident has been resolved.
Posted about 1 month ago. Aug 15, 2019 - 09:44 PDT
Identified
Orders for Argos eGift Cards are currently failing through our supplier. We will post an update when this reward is once again available.

The following UTIDs are affected:

U324815
U441584
U537455
U319670
U847943
U837857
U635691
U529156
U625363
Posted about 1 month ago. Aug 13, 2019 - 23:23 PDT
This incident affected: Item.