Item Outage -MALL.CZ Gift Certificate Kc 1000
Incident Report for Tango Card
Resolved
This outage has ended.
Posted 25 days ago. Sep 27, 2019 - 11:51 PDT
Monitoring
We are experiencing an outage on MALL.CZ Gift Certificate Kc 1000. The affected UTID is U693453.

More is on order, and we are working with our vendor to get this back in stock, as soon as possible.
Posted about 1 month ago. Sep 16, 2019 - 12:21 PDT
This incident affected: Item.