Interruptions to our main USA supplier's system

Incident Report for Tango Card

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 13:21 PDT

Monitoring

Tango Systems experienced interruptions with our main USA supplier's system from 11:45 to 12:15 PM PDT
This issue is resolving and Engineering teams are continuing to monitor.
Posted Jul 03, 2025 - 13:20 PDT
This incident affected: Item.