Item Outage: NFL Shop $10 - 10/2/19
Incident Report for Tango Card
Resolved
This outage has been resolved
Posted 15 days ago. Oct 07, 2019 - 14:36 PDT
Identified
We are currently out of inventory for NFL Shop $10. We will post an update when this reward is once again available.

The affected UTID is U439954.
Posted 20 days ago. Oct 02, 2019 - 10:25 PDT
This incident affected: Item.