Reward Link Experiencing Issues
Incident Report for Tango Card
Resolved
We have identified and resolved the issue. Reward Link is back up in production.
Posted Nov 16, 2020 - 12:25 PST
Update
Reward Link is down in production as we continue to investigate these issues.
Posted Nov 16, 2020 - 11:36 PST
Investigating
We are experiencing issues with Reward Link catalogs displaying incorrect brands and incorrect recipient email address. We are actively investigating.
Posted Nov 16, 2020 - 11:09 PST
This incident affected: Reward Link - Production.