Item Outage: Esso $10 - 10/1/19
Incident Report for Tango Card
Resolved
This outage has ended.
Posted 20 days ago. Oct 02, 2019 - 12:41 PDT
Identified
We are currently out of inventory for Esso $10. We will post an update when this reward is once again available.

The affected UTID is: U268151.
Posted 21 days ago. Oct 01, 2019 - 17:19 PDT
This incident affected: Item.