Item Outage - Coles eGift Card $5.00
Incident Report for Tango Card
Resolved
This outage has ended.
Posted 22 days ago. Sep 30, 2019 - 07:37 PDT
Identified
We are experiencing and outage on Coles eGift Card $5.00. The affected UTID is UTID:U314250.

More is on order, and we expect to have it back in stock soon.
Posted 22 days ago. Sep 30, 2019 - 06:42 PDT
This incident affected: Item.