Item Outage - zooplus.de Gutscheine 25 €
Incident Report for Tango Card
Resolved
This incident has been resolved.
Posted Feb 07, 2020 - 15:23 PST
Identified
We are experiencing an outage for zooplus.de Gutscheine 25 €. More is on order, and we expect to have this back in stock this week.

The affected UTID is UTID:U855195.
Posted Feb 04, 2020 - 08:19 PST
This incident affected: Item.