Inactive Item - JCPenney E-Gift Card $5.00
Incident Report for Tango Card
Resolved
This item has been reactivated.
Posted about 7 hours ago. Sep 16, 2019 - 15:45 PDT
Monitoring
We have inactivated JCPenney E-Gift Card $5.00, UTID:U333200. Currently, there is no estimate when this item will be reactivated, or in stock again.
Posted 4 days ago. Sep 12, 2019 - 15:07 PDT
This incident affected: Item.