Item Outage - M. Video E-Card ₽1500 - 12/19/2019
Incident Report for Tango Card
Resolved
This incident has been resolved.
Posted May 28, 2020 - 14:36 PDT
Identified
M. Video E-Card ₽1500 is currently unavailable. We will post an update when this reward is once again available.

The affected UTID is: U672907
Posted Dec 19, 2019 - 21:56 PST
This incident affected: Item.