Item Outage - Argos Gift Cards - 10/4/2019
Incident Report for Tango Card
Resolved
This incident has been resolved.
Posted 18 days ago. Oct 04, 2019 - 08:35 PDT
Identified
Orders for Argos eGift Cards are currently failing through our supplier. We will post an update when this reward is once again available.

The following UTIDs are affected:

U324815
U441584
U537455
U319670
U847943
U837857
U635691
U529156
U625363
Posted 18 days ago. Oct 04, 2019 - 02:42 PDT
This incident affected: Item.