Item Outage - Americanas.com Gift Card $R100 - 8/23/2019
Incident Report for Tango Card
Resolved
This outage is resolved.
Posted 14 days ago. Sep 03, 2019 - 09:00 PDT
Identified
We are experiencing an outage on Americanas.com Gift Card $R100, UTID:U050582. More is on order, and we expect to have this in stock, soon.
Posted 24 days ago. Aug 23, 2019 - 15:04 PDT
This incident affected: Item.