Item Outage: EMAG.RO $50.00 - 10/1/19
Incident Report for Tango Card
Resolved
This outage has been resolved.
Posted 14 days ago. Oct 08, 2019 - 09:04 PDT
Identified
We are currently out of inventory for EMAG.RO $50.00. We will post an update when this reward is once again available.

The affected UTID is U734409.
Posted 21 days ago. Oct 01, 2019 - 05:41 PDT
This incident affected: Item.