Item Outage : Nike E-Gift France €25 - UTID:U323931
Incident Report for Tango Card
Resolved
This outage is resolved.
Posted about 1 month ago. Aug 14, 2019 - 16:39 PDT
Monitoring
We are experiencing an outage on Nike E-Gift France €25, UTID:U323931. More is on order, and we expect to have this in stock, soon.
Posted about 2 months ago. Jul 31, 2019 - 21:50 PDT
This incident affected: Item.