Item Outage: Lazada Gift Card S$100 - 8/22/2019
Incident Report for Tango Card
Resolved
This incident has been resolved.
Posted 25 days ago. Aug 23, 2019 - 08:16 PDT
Identified
Orders for Lazada Gift Card S$100 rewards are failing through our supplier. We will post an update when this reward is once again available.

The following UTID is affected: U917793
Posted 25 days ago. Aug 22, 2019 - 16:33 PDT
This incident affected: Item.