Item Outage - GiftPax eGift Card $25.00
Incident Report for Tango Card
Resolved
This incident has been resolved.
Posted 12 days ago. Sep 04, 2019 - 14:42 PDT
Monitoring
We are experiencing an outage on GiftPax eGift Card $25.00. More is on order, and we expect to have this back in stock, soon. The affected UTID is U514692.
Posted 20 days ago. Aug 27, 2019 - 19:08 PDT
This incident affected: Item.