Item Outage - Lazada Gift Card S$75 - 10/4/2019
Incident Report for Tango Card
Resolved
This incident has been resolved.
Posted 13 days ago. Oct 09, 2019 - 15:38 PDT
Investigating
Orders for Lazada Gift Cards S$75 are currently failing though our supplier. We will post an update when this reward is once again available.

The affected UTID is U926844.
Posted 18 days ago. Oct 04, 2019 - 13:58 PDT
This incident affected: Item.