Some customers experiencing slower load times for Tango portal

Incident Report for Tango Card

Resolved

This incident has been resolved.
Posted Aug 04, 2026 - 12:50 PDT

Monitoring

We are monitoring.
Posted Aug 04, 2026 - 10:32 PDT

Identified

The issue has been identified and we are monitoring.
Posted Aug 04, 2026 - 10:31 PDT

Investigating

We are currently investigating the issue.
Posted Aug 04, 2026 - 10:25 PDT
This incident affected: Tango Portal.