Item Outage: Netshoes R$30 - 10/2/19
Incident Report for Tango Card
Resolved
This outage has ended.
Posted 8 days ago. Oct 14, 2019 - 14:19 PDT
Identified
We are currently out of inventory for Netshoes R$30. We will post an update when this reward is once again available.

The affected UTID is U728768.
Posted 20 days ago. Oct 02, 2019 - 07:23 PDT
This incident affected: Item.