Item Outage - Google Play UK - 8/15/2019
Incident Report for Tango Card
Resolved
This incident incident is now resolved. Google Play UK gift codes are once again available.
Posted about 1 month ago. Aug 16, 2019 - 09:18 PDT
Update
We are continuing to work on a fix for this issue.
Posted about 1 month ago. Aug 15, 2019 - 14:20 PDT
Identified
Google Play UK gift codes are temporarily unavailable through our supplier. We will post an update as soon as we learn more.
Posted about 1 month ago. Aug 15, 2019 - 14:06 PDT
This incident affected: Item.