Item Outage: Lowe's E-Gift Card - 8/30/2019
Incident Report for Tango Card
Resolved
This incident has been resolved.
Posted 17 days ago. Aug 30, 2019 - 12:56 PDT
Identified
Orders for Lowe's E-Gift Cards are currently failing through our supplier. We will post an update when this reward is once again available.

The following UTID is affected: U589797
Posted 18 days ago. Aug 30, 2019 - 07:37 PDT
This incident affected: Item.