Item Outage - App Store & iTunes Canada Gift Card $25.00 - 12/17/19
Incident Report for Tango Card
Resolved
This outage has been resolved.
Posted Feb 04, 2020 - 10:31 PST
Identified
App Store & iTunes Canada Gift Card $25.00 is currently unavailable. We will post an update when this reward is once again available.

The affected UTID is: U674362
Posted Dec 17, 2019 - 09:04 PST
This incident affected: Item.