Item Outage - Landmark eGift ₱500
Incident Report for Tango Card
Resolved
This outage has ended.
Posted 11 days ago. Sep 06, 2019 - 09:22 PDT
Monitoring
We are experiencing an outage on Landmark eGift ₱500. The affected UTID is U578423.

More is on order, and we expect to have this back in stock, today.
Posted 11 days ago. Sep 06, 2019 - 02:09 PDT
This incident affected: Item.