Item Outage - Google Play $50.00
Incident Report for Tango Card
Resolved
This outage has ended.
Posted 21 days ago. Oct 01, 2019 - 08:33 PDT
Identified
We are currently out of inventory for Googe Play $50. We will post an update when this reward is once again available.

The affected UTID is U885532.
Posted 22 days ago. Sep 30, 2019 - 21:30 PDT
This incident affected: Item.