Item Outage: David Jones eGift Card $25.00 - 10/1/2019
Incident Report for Tango Card
Resolved
This outage has ended
Posted 21 days ago. Oct 01, 2019 - 08:22 PDT
Identified
We are currently out of inventory for David Jones eGift Card $25.00. We will post an update when this reward is once again available.

The affected UTID is: U114035
Posted 21 days ago. Oct 01, 2019 - 01:32 PDT
This incident affected: Item.