Item Outage - Submarino.com Virtual Gift Card R$100 - 10/1/2020
Incident Report for Tango Card
Resolved
This outage has been resolved.
Posted Oct 14, 2020 - 11:10 PDT
Identified
Submarino.com Virtual Gift Card R$100 is currently unavailable. We will post an update when this reward is once again available.

The affected UTID is: U613310
Posted Oct 01, 2020 - 08:59 PDT
This incident affected: Item.