Inactive Item - The Home Depot - 8/4/2020
Incident Report for Tango Card
Resolved
This incident has been resolved.
Posted Aug 10, 2020 - 11:47 PDT
Identified
The Home Depot eGift Card is temporarily unavailable and has been set to inactive in our system. Will provide updates as we get them.

The affected UTIDs are: U231646 and U008583
Posted Aug 04, 2020 - 08:49 PDT
This incident affected: Item.