Item Outage: Grab Gift Card S$5 - 10/17/2019
Incident Report for Tango Card
Resolved
This outage has been resolved.
Posted Oct 21, 2019 - 14:10 PDT
Identified
Orders for Grab Gift Cards S$5 are currently failing though our supplier. We will post an update when this reward is once again available.

The affected UTID is U582168.
Posted Oct 17, 2019 - 11:01 PDT
This incident affected: Item.