Item Outage - JCPenney E-Gift Card $25.00
Incident Report for Tango Card
Resolved
This outage is resolved.
Posted 22 days ago. Sep 30, 2019 - 09:33 PDT
Identified
We are experiencing and outage on JCPenney E-Gift Card $25.00. The affected UTID is UTID:U424837.

More is on order, and we expect to have it back in stock soon.
Posted 24 days ago. Sep 28, 2019 - 06:44 PDT
This incident affected: Item.