Item Outage: MALL.CZ Kč 500 - 10/1/19
Incident Report for Tango Card
Resolved
This outage has ended.
Posted 21 days ago. Oct 01, 2019 - 09:09 PDT
Identified
We are currently out of inventory for MALL.CZ Kč 500. We will post an update when this reward is once again available.

The affected UTID is U057939.
Posted 21 days ago. Oct 01, 2019 - 06:06 PDT
This incident affected: Item.