Item Outage - zooplus.de Gutscheine 10 € - 2/13/2020
Incident Report for Tango Card
Resolved
This outage has been resolved.
Posted Feb 14, 2020 - 09:47 PST
Identified
zooplus.de Gutscheine 10 € is currently unavailable. We will post an update when this reward is once again available.

The affected UTID is: U453277
Posted Feb 13, 2020 - 08:50 PST
This incident affected: Item.