Item Outage - Redbox Card $10.00
Incident Report for Tango Card
Resolved
This outage has ended.
Posted 19 days ago. Aug 28, 2019 - 12:56 PDT
Monitoring
We are currently experiencing an outage of Redbox Card $10.00. More is on order, and we expect to have this back in stock, shortly.

The affected UTID is U593378.
Posted 25 days ago. Aug 22, 2019 - 17:05 PDT
This incident affected: Item.